Menu Close

R6S black screens

What is Moss ? forums Bugs R6S black screens

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
  • #2503

    Hi, I’m currently running Windows 10 64bit and MOSS keeps taking black screenshots. after I stop capturing all of the screenshots are black and if I try to check the integrity of the files it says they are corrupted.


    My NVIDIA 3D Settings are:

    High Performance NVIDIA Processor
    Ambient Occlusion Not supported for this application
    Anisotropic filtering Use global setting (application controlled)
    Antialiasing – FXAA Use global setting (Off)
    Antialiasing – Mode Use global setting (application controlled)
    Antialiasing – Setting Use global setting (application controlled)
    Antialiasing – Transparency Use global setting (Off)
    CUDA – GPUs Use global setting (All)
    Maximum pre-rendered frames Use global setting (Use the 3D application setting)
    Multi-display/mixed-GPU acceleration Single display performance mode
    Power management mode Prefer maximum performance
    Shader Cache On
    Texture filtering – Anisotropic sample options Off
    Texture filtering – Negative LOD bias Clamp
    Texture filtering – Quality High Performance
    Texture filtering – Trilinear optimization Off
    Threaded optimization Auto
    Triple buffering Off
    Vertical sync (Use the 3D application setting)
    Virtual reality pre-rendered frames 1

    I’m using MOSS, I don’t even know if any of this is useful to you but I was messing around and tried to copy my friends settings and the screen capture worked WHILE I was copying his settings. I don’t know if it was a coincidence or what but I also tried running MOSS on my brother’s laptop and I still get black screens.


    the only known issue on windows 10 is about laptop and discrete GPU.
    the fix is pretty simple : right click on Moss and attach it to Intel GPU (which is the main one) not to the Nvidia/ATI one , I have no way to do it from the program itself (NvOptimusEnablement has no disable command).


    Would this work?
    Right click MOSS -> Run with graphics processor -> Integrated graphics -> Gives me a prompt on screen that says “You don’t have the privilege to select the graphics processor in this menu” “Select the preferred graphics processor for this program in the NVIDIA Control Panel”

    I already tried to go into the NVIDIA control panel and change the preferred graphic processor to “Integrated graphics” but when I did the pictures were still black. Maybe i’m not fully understanding your response which brings me to 3 questions.

    Do you have enough information to what my problem might be? (not doubting your answer just thought you might need a log file of some sort)

    By attaching MOSS to use the Integrated graphics with NVIDIA Control Panel am I doing everything right?

    Is there a program that can force MOSS to attach to my Integrated graphics?


    it should work if your case is the one I described.
    But yes, you can post a log file, I just need the first part (you can hide IP and serial, if you like)
    And no there is no way, so far I know, to force a program to attach to Intel neither a code way to do it


    Thanks for the fast replies I really appreciate you trying to help me.
    Pastebin of logfile:
    Picture of NVIDIA Control Panel:


    there is a mess beetween your EXE , you run a program called mossbeta.exe and set your nvidia stuff to another mossX64 (I cant read the end). but obviously it’s not the same and it wont work


    So basically all of the MOSS exe files that I have need to be on the same NVIDIA 3D settings?

    MOSS beta NVIDIA settings:
    MOSS 64 NVIDIA eettings:

    I downloaded MOSS beta after MOSS 64 wasn’t working just hoping for a miracle for some reason. but I still had black screens before I downloaded the MOSS beta.
    When I select the preferred graphics processor and set it to integrated graphics all of the custom settings are grayed out but as you can see from both of the pictures the settings are different for MOSS beta and MOSS 64. Is that what is causing issues?

    Like I said in a previous reply I was copying some of my friends settings and it was taking screenshots of my desktop for a short period of time but that only happened when my game was in Windowed mode.

    First time I ever ran MOSS logfile:
    Logfile from when it worked for a split second:


    if it works to shoot desktop images, it doesnt work. Moss is supporsed to shoot the game not the desktop.
    however there is only ONE version you can use , whichever the one you start it will update to the same version (with a special case for the beta when it’s more recent than production one, but it’s not the case right now).
    so remove any version you have , download the last from my site , and apply the nvidia control panel trick to this version , it will works for you as it works for thousands of players


    I came back to update you on the situation, after deleting both Moss 64, Moss beta, and the Moss folder I re-downloaded Moss 64 and set the NVIDIA 3D settings to Integrated graphics. Everything seems to be working great. Playing in fullscreen works perfectly and I get no lag spikes while Moss is running. Thanks for taking your time and reading all the logfiles to help me fix it I REALLY appreciate it.

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.