MOSS for Cod1

Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
    Posts
  • #2451
    coP
    Participant

    Hi Guys,

    im from a little community who still plays the first version of CoD 1.
    We have a few hundred players who play in FunWar, Tournaments and so on against each others.

    As the first Version of CoD 1 has no Anti Cheat Tool we are looking a long time for a good solution.

    Your tool seems to run fine, its simple and has a list of processes in it. Thats exacly what we need to including Ingame Screenshots.

    Is it maybe possible to make MOSS compatible with CoD 1.1?

    I already tried it and the processes list was good but the ingame screenshots where just black.

    Would be rly nice if you could help us with it.

    Best regards,
    coP

    #2452
    ADM_nohope
    Keymaster

    sure , please just give me some information about the game :
    Game name : CoD 1.1
    Game EXE name : ?
    Files to monitor or capture , with their path to the game : ini or cfg or any type, and if you want to get them captured all along the game or just monitored against changes

    #2453
    coP
    Participant

    Nice thank you :).

    Game Name: Call of Duty Version 1.1 (or Short CoD 1.1)
    Game EXE name: CoDMP.exe

    Files to monitor:
    config_mp.cfg

    I would just monitored it against changes bcs some people bind there rconpasswords in it and that would be bad if someone see’s it.

    The most used Cheat in CoD 1.1 is CoDBot by Taurin.

    Its gets actived with the cvars:
    /set fire 1
    /set aim 1
    /set wallhack 1
    /set esp 1

    I dont know if there is a way to capture this changes but when it would be rly nice.

    #2455
    ADM_nohope
    Keymaster

    added in 4.0.8 released today
    I assumed the cfg is i nsame location others cods

    #2456
    coP
    Participant

    Wow rly fast thank you very much. The config is in the main folder of cod (i think in cod2 and 4 its the same location C:\Program Files (x86)\Call of Duty\Main).

    #2457
    ADM_nohope
    Keymaster

    not really , the real file location is stored in another file

    #2458
    coP
    Participant

    Here the first test:
    http://sniper-clan.com/wp-content/uploads/2017/07/2017-07-24_200306_1176815731_1768267648.zip

    Unfortunately the Screenshots are all black :(.

    #2459
    ADM_nohope
    Keymaster

    I updated the file location to your version , and I dont have a black screen problem on windows 10. I will test on some Windows 7

    #2460
    coP
    Participant

    The path is changeable, the most ppl have it unser C:\COD\… etc.

    I have also another installation of CoD 1.1 under:
    D:\Spiele Downloads\Call of Duty 1.1

    When i start MOSS the First thing i get is the Message:
    “The color scheme has been changed”
    And some colors from my Windows change but the programs starts. Then i chose Parameters CoD 1.1. After this i make Capture -> Start and run the game.

    Its say “CoD 1.1 Capture is running”.

    If i close the Game it still says: “CoD 1.1 Capture is running” and i need to click Capture -> Stop then the program minimized itself and the colors of my Windows change back to normal.

    If i open the minimzed Moss aagain then there is a Messge: Capture stopped and the path of the archive file.

    I tested it again and runed CoD 1.1 in Windows Mode (Not Fullscreen). With that it seems to work. Here is a Archiv File with Window Mode: http://sniper-clan.com/wp-content/uploads/2017/07/2017-07-25_002147_1176815731_1768267648.zip

    So the problem seems to be the fullscreen mode. Would be nice if we get this solved, then its rly usable for us and we can finally play Funwars with a good Cheat Protection :).

    #2461
    ADM_nohope
    Keymaster

    I posted in beta a version which should fix the capture file issue
    concerning the windows 7 issue , I made a quick test where disabling aero over cod_mp.exe directly should clear the problem (right clic and tick some compatibilities stuff )

    #2462
    coP
    Participant

    Hi,

    thank you again i tested the beta. It capured now the config_mp.cfg but unfortunately it capured the whole cfg including all secret password binds.

    The screenshots are also black again.

    Here is the newest test:
    http://sniper-clan.com/wp-content/uploads/2017/07/2017-07-26_222708_1176815731_1768267648.zip

    As admin of alot of servers i deleted my config from the archive file.

    #2463
    ADM_nohope
    Keymaster

    I will remove the confidentials lines from file , just let me know how to detect them. otherwise I have not to capture the file (done for now)

    I will do more tests on 7 , could you send me a dxdiag report but definitivly there is no reason to be unable to capture the screens unless the game is below dx9.
    I put a GDI version on beta (didnt had time to update the version #) if this the case but I doubt

    #2464
    coP
    Participant

    There are 3 kind of binds for Passswords:
    bind UPARROW “rconpassword xyz”
    bind DOWNARROW “say !on username password”
    bind DOWNARROW “say !login username password”

    Here is the dxdiag report:
    http://sniper-clan.com/wp-content/uploads/2017/07/DxDiag.txt

    I testet the new beta with GDI version but its still the same with black screenshots.

    #2478
    coP
    Participant

    Hi, do you have any update for me? Or do you need some more informations?

    #2481
    ADM_nohope
    Keymaster

    I didnt work on subject , I have to code a specific part for your file with password to analyse file captured content and strip your strings

    about the black screen issue , I dont reproduce it on a windows 7 , which is more ennoying as there is no chance this game use any dx11 features which genreally create the problem

Viewing 15 posts - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.

Play Cool , Play Hard but Play Fair